Skip to main content

What Are The Compatible Devices & OS? - Knowledgebase / FAQs - VSee Helpdesk

What Are The Compatible Devices & OS?

While VSee calling can be used with a wide variety of devices, there are some points to consider to ensure optimal functioning. Please refer to the list of compatible devices and OS below.


What are the compatible device OS?

Which smartphones are supported?

What are the supported internet browsers?

 

Device OS

Windows

  • Windows 7 or later

  • 2GHz dual-core CPU for up to 3-way calls

  • *Intel® Core™ i5 or i7 CPU is recommended for group video calls

  • *VSee only works on Windows Surface tablet with full Windows OS.


macOS

  • OS X 10.11 (El Capitan) or later

Known compatibility issues with some macOS software:

  • Hear from Prosoft: An application to improve the audio output on Macs or PCs. It causes VSee to crash on opening any audio channel. The vendor claims that version 1.1.6 fixes this issue.

  • Audio Hijack Pro from Rogue Ameoba: This application allows users to record audio from any application. It causes VSee to crash on opening any audio channel. There is no known resolution other than disabling Audio Hijack.

  • MacKeeper from ZeoBit: This somewhat controversial software is a bundle of system utilities. It has been reported to cause VSee to crash. There is no known resolution other than removing it.


Chrome OS and Linux

  • VSee Clinic In-browser calling feature works with Chrome browsers.

  • VSee Messenger is not compatible yet with this OS.


iOS & iPadOS

  • iOS & iPadOS 11 or later

  • iPad Air or newer

  • iPad Mini 2nd generation or newer

  • iPhone SE or newer


Android

Minimum device specifications:

  • Android 5.0 (Lollipop) or later

  • NEON compatible ARM processor or x86 processor

  • Dual-core CPU

  • Amazon Fire phone and tablets 2014 or later

Recommended device specifications:

  • Google Pixel 2 or newer

  • Samsung Galaxy S8 or newer

  • Samsung Galaxy Note 8 or newer


Internet Browsers

JavaScript must be enabled and cookies must be allowed for VSee Clinic to function well.

 

Google Chrome 83 or later

This is highly recommended. VSee Clinic works best on Google Chrome.

  • For Android: "Desktop site" option must be turned off under the Chrome menu.

  • You can check the Google Chrome version by clicking on the ellipsis (...) on the upper-right side of Google Chrome > Settings > About Chrome


Safari 14 or later


  • For iOS: "REQUEST DESKTOP WEBSITE" must be turned off under iOS Settings -> Safari

 

Microsoft Edge 83 or later

  • For older versions, the platform will provide the user the option to download and install the VSee app to start the call.


Internet Explorer

  • Support ended as of Nov 30, 2020 

 

Firefox, Opera

- Temporarily not supported

 

Note: Webchat is supported on Android (Chrome) and iOS (Safari).

 

Scope and Limitations

  • If you are not sure about your device OS and internet browser, please refer to your system settings or device manual.

  • The latest version of the device OS and internet browser is best. Please refer to your device or OS help section on how to update it.


If you have any questions, please contact us at help@vsee.com


Last updated on: 29 April 2022

Helpful Unhelpful